Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server

From: Date: Wed, 23 Oct 2013 00:21:18 +0000
Subject: Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-69788@lists.php.net to get a copy of this message
On Wed, Oct 23, 2013 at 9:05 AM, Andrea Faulds <ajf@ajf.me> wrote: > On 23/10/2013 01:02, Yasuo Ohgaki wrote: > >> >> I'm not following the discussion, but if name matters why don't you use >> generic name >> function and alias of it? >> >> > There's already a generic alias of apache_request_headers(), namely > getallheaders(). There's not yet one for apache_response_headers(), but I > don't think it's within the scope of this request to add one. I might add > one with a separate request, mind. getallheaders() is not good name since it does not follow current naming convention. Why don't we have - sapi_request_headers() - sapi_response_headers() or - http_request_headers() - http_response_headers() Just an idea. Regards, -- Yasuo Ohgaki yohgaki@ohgaki.net

« previous php.internals (#69788) next »