Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server

From: Date: Wed, 23 Oct 2013 01:20:39 +0000
Subject: Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server
References: 1 2 3 4 5 6 7  Groups: php.internals 
Request: Send a blank email to internals+get-69794@lists.php.net to get a copy of this message
Hi Andrea, On Wed, Oct 23, 2013 at 9:26 AM, Andrea Faulds <ajf@ajf.me> wrote: > But it already exists. Why add *another* alias? We should make > apache_response_headers() have a consistent alias, something like > getresponseheaders(). Then we'll have: > > * apache_request_headers() and getallheaders() > * apache_response_headers() and getresponseheaders() > > Under your proposal, we'd have: > > * apache_request_headers(), sapi_request_headers(), and getallheaders() > * apache_response_headers() and sapi_response_headers() > It is not good idea introducing non-standard function name in new releases. getallheaders() should be depreciated in the future as it does not conform current naming convention. How about this? PHP 5.6: Document getallhaeders() as deprecated. PHP 5.7: Raise deprecated error for getallheaders(). PHP 6.x: Remove getallheaders() adoption is done. (Perhaps 5 or 10 years from now?) It would be nicer cleaning up mess in the long run, rather than introducing new mess. IMHO. Regards, -- Yasuo Ohgaki yohgaki@ohgaki.net

« previous php.internals (#69794) next »