Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server
| From: | Rowan Collins | Date: | Wed, 23 Oct 2013 13:47:02 +0000 |
| Subject: | Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server | ||
| References: | 1 2 3 4 5 6 7 8 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-69803@lists.php.net to get a copy of this message | ||
Yasuo Ohgaki wrote (on 23/10/2013):
It is not good idea introducing non-standard function name in new releases. getallheaders() should be depreciated in the future as it does not conform current naming convention.While I would tend to agree that adding more "badly" named functions/aliases would be unfortunate, I would have thought removing the "bad" name would risk opening a rather large can of worms. From the prominently linked blog post on RFCs [https://blogs.oracle.com/opal/entry/the_mysterious_php_rfc_process]:
Don't start an RFC (or mail list discussion) about standardizing PHP function names and function argument orders. [...] This has been discussed ad infinitum. Review previous discussions and feel free to fork PHP on github.IMHO, there would need to be a pretty strong argument for this particular function to be permanently renamed without reopening that discussion for all the other poorly named functions in core. (Note: this is NOT an invitation to reopen that discussion!) Perhaps a better idea (which already came up recently) would be to create a new module for dealing with SAPI I/O (request body data, environment vars, cookies, etc) and include HTTP header handling in that. This could also allow better symmetry for *setting* response headers, to replace header(), in the same way as setcookie()/$_COOKIE. Regards, -- Rowan Collins [IMSoP]