Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server
| From: | Andrea Faulds | Date: | Wed, 23 Oct 2013 00:26:45 +0000 |
| Subject: | Re: [PATCH] Add apache_request_headers() and apache_response_headers() to the CLI server | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-69789@lists.php.net to get a copy of this message | ||
On 23/10/2013 01:21, Yasuo Ohgaki wrote:
getallheaders() is not good name since it does not follow current naming convention.But it already exists. Why add *another* alias? We should make apache_response_headers() have a consistent alias, something like getresponseheaders(). Then we'll have: * apache_request_headers() and getallheaders() * apache_response_headers() and getresponseheaders() Under your proposal, we'd have: * apache_request_headers(), sapi_request_headers(), and getallheaders() * apache_response_headers() and sapi_response_headers() I'd much rather go with my own proposal. It avoids introducing a new set of aliases, but instead completes the existing one, however imperfect it may seem. Cheers, -- Andrea Faulds http://ajf.me/