Re: [RFC] Revert/extend/postpone original RFC about read_only, lazy_write sessions
| From: | Andrey Andreev | Date: | Sun, 16 Mar 2014 01:27:24 +0000 |
| Subject: | Re: [RFC] Revert/extend/postpone original RFC about read_only, lazy_write sessions | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-73186@lists.php.net to get a copy of this message | ||
> "lazy_write" is not accepted. So you don't need to mention it in the RFC.
Yes, it is.
People (including yourself) have voted +1 for "Read only, lazy write option".
> "read_only" option is better/much faster version of "session_start();
> session_commit()".
> If the name "read_only" is confusing, better name would be appreciated.
I know what it is, Yasuo ... half of the RFC is about it, please read
it carefully.
> "write short cut" is there, since it does not affect
> existing behavior
> nor save handlers at all.
The public probably doesn't know what "write short cut" is, because
it's only mentioned in a separate discussion.
So, for the public, it is this: https://bugs.php.net/bug.php?id=17860
... or in other words, a non-optional version of 'lazy_write'.
It does affect current functionality ... it's described in the RFC as
'lazy_write'.
Regards,
Andrey.