Re: [RFC] Revert/extend/postpone original RFC about read_only, lazy_write sessions
| From: | Yasuo Ohgaki | Date: | Sun, 16 Mar 2014 01:39:42 +0000 |
| Subject: | Re: [RFC] Revert/extend/postpone original RFC about read_only, lazy_write sessions | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-73188@lists.php.net to get a copy of this message | ||
Hi Andrey,
On Sun, Mar 16, 2014 at 10:12 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote:
> Hi Andrey,
>
> On Sun, Mar 16, 2014 at 3:24 AM, Andrey Andreev <narf@devilix.net> wrote:
>
>> I'm announcing the following RFC for discussion, with the hope that it
>> can get through before the PHP 5.6 release:
>> https://wiki.php.net/rfc/session-read_only-lazy_write
>>
>> As noted in it, I don't feel like
>> https://wiki.php.net/rfc/session-lock-ini was handled
>> properly. Lack
>> of attention to it alone is demonstrated by the fact that a total of
>> only 10 people have voted. I hope that this follow-up receives more
>> attention, so that we can avoid a potential mess.
>>
>
> "lazy_write" is not accepted. So you don't need to mention it in the RFC.
>
> "read_only" option is better/much faster version of "session_start();
> session_commit()".
> If the name "read_only" is confusing, better name would be appreciated.
>
> BTW, I have to commit accepted RFC change now. Option name may be changed
> before release. "write short cut" is there, since it does not affect
> existing behavior
> nor save handlers at all.
>
Oops, Proposal 2 is actually a "write short circuit". Therefore, if you
think this is not
needed, you may mention it in the RFC. I was mixed up with "unsafe_lock"
option, sorry.
I'll make changes required, then merge it soon.
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net