Re: [RFC] Revert/extend/postpone original RFC about read_only, lazy_write sessions

From: Date: Fri, 21 Mar 2014 13:46:07 +0000
Subject: Re: [RFC] Revert/extend/postpone original RFC about read_only, lazy_write sessions
References: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20  Groups: php.internals 
Request: Send a blank email to internals+get-73357@lists.php.net to get a copy of this message
Hi, On Thu, Mar 20, 2014 at 8:35 PM, John LeSueur <john.lesueur@gmail.com> wrote: > Just an unimportant note on the name of the function. Having done this in a > custom session handler, I have always thought of this as an analogue to the > "touch" command for the filesystem. Naming this SessionHandler::touch() > would probably appeal to those familiar with linux or other posix compliant > systems. Yes, probably ... but it would be confusing for those not familiar with UNIX-based OSes, and especially confusing when you implement a session handler that is not file-system based. Anyway, if it gets "merged" into write(), that's irrelevant and this is the better option, IMO. Cheers, Andrey.

« previous php.internals (#73357) next »