Re: Re: Session: deprecating create_sid() method and add createSid()?
| From: | Stas Malyshev | Date: | Mon, 17 Mar 2014 22:49:06 +0000 |
| Subject: | Re: Re: Session: deprecating create_sid() method and add createSid()? | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-73251@lists.php.net to get a copy of this message | ||
Hi!
> Since create_sid() method is added in 5.5.1 and it's not documented yet.
> I would like to propose renaming it to createSid() for both 5.5 and 5.6.
Renaming is a BC break and it's there for 10 releases already, so it'd
be a no go. You can add an alias of createSid, but then you'd have to be
very careful so that overriding both create_sid and createSid would work
the same (including when parent:: is involved). If it's hard to do
cleanly then I'd rather prefer keeping create_sid.
--
Stanislav Malyshev, Software Architect
SugarCRM: http://www.sugarcrm.com/
(408)454-6900 ext. 227