Re: [RFC] Bare Name Array

From: Date: Sun, 01 Jun 2014 19:46:28 +0000
Subject: Re: [RFC] Bare Name Array
References: 1 2 3 4  Groups: php.internals 
Request: Send a blank email to internals+get-74679@lists.php.net to get a copy of this message
On 1 Jun 2014, at 20:34, Stas Malyshev <smalyshev@sugarcrm.com> wrote: > Hi! > >> Well, we already replaced array() with []. > > That was readability improvement. But it's not a license to make the > language unreadable without any real gain in readability. I don’t think readability would be hurt. [ key: value ] is as easy to understand as [ “key” => value ], and likely very familiar to people who have dealt with JavaScript or JSON. The :> operator does not look too far off from -> or =>, too, though again, I’m willing to use a better alternative if one exists. It also happens to be the C99 digraph for ], take that as you will. :) -- Andrea Faulds http://ajf.me/

« previous php.internals (#74679) next »