Re: [RFC] Bare Name Array

From: Date: Mon, 02 Jun 2014 09:13:28 +0000
Subject: Re: [RFC] Bare Name Array
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-74695@lists.php.net to get a copy of this message
I'm personally against it adding :> It's just pointles and kind'a looks like an object access. Not to mention that one time access that deep is normal. but if you are looping through a lot of data - it's quite an overhead and encoruaging users to do it that way is just plain wrong to me. As to the 'stringKey' : 3 - don't realy have anything against it, just the readability is not that great when you put it in on larger array definitions. => is very clear about what you are looking at and what it does and is very visible. So, personaly I would prefer to have just one way of defining key => value in PHP code.

« previous php.internals (#74695) next »