Re: new json, push generated file?

From: Date: Mon, 09 Feb 2015 13:55:36 +0000
Subject: Re: new json, push generated file?
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-82283@lists.php.net to get a copy of this message
On Feb 9, 2015 4:46 PM, "Jakub Zelenka" <bukka@php.net> wrote: > > On Mon, Feb 9, 2015 at 9:18 AM, Anatol Belski <anatol.php@belski.net> wrote: >> >> Hi, >> >> On Mon, February 9, 2015 07:33, Xinchen Hui wrote: >> > Hey: >> > >> > >> > >> > >> > On Mon, Feb 9, 2015 at 1:44 PM, Pierre Joye <pierre.php@gmail.com> wrote: >> > >> >> On Mon, Feb 9, 2015 at 11:10 AM, Xinchen Hui <laruence@php.net> wrote: >> >> >> >>> Hey: >> >>> >> >>> >> >>> On Mon, Feb 9, 2015 at 10:40 AM, Pierre Joye <pierre.php@gmail.com> >> >>> wrote: >> >>> >> >>>> hi, >> >>>> >> >>>> Should we push json_parser.tab.c? Which is generated (re2c), just >> >>>> like what is done in date or other? >> >>>> >> >>> I think we should, and also use a better name...(.tab.c?) >> >>> >> >> >> >> that too :) >> > simply, json_parser.c is good >> > >> > something like: >> > https://gist.github.com/laruence/f33903266cec737088aa >> > >> I'd be for applying this as well. Also, just added the generation calls to >> config.w32, but actulaly a checked in file were much simpler to handle. >> >> Regards >> >> Anatol > > > Hi, > > The re2c generated files are pushed (see https://github.com/php/php-src/blob/master/ext/json/json_scanner.c ). The json_parser.tab.c is a BISON generated file. I haven't pushed that file because we don't have bison generated files in repo (e.g. zend_language_parser.c). I'm actually for pushing that file as well but then we should probably push zend_language_parser.c too. Thoughts? > > The name .tab.c is a standard name for bison files ( see last paragraph http://www.gnu.org/software/bison/manual/html_node/Rpcalc-Generate.html#Rpcalc-Generate ). I think that it can be changed but not sure if it makes much sense. The .tab.c says that it's a C file with parsing tables... I still think it is better to have this file applied. It is not like they will change every 2nd day. > Cheers > > Jakub >

« previous php.internals (#82283) next »