Re: Re: [RFC] Exceptions in the engine
| From: | Yasuo Ohgaki | Date: | Fri, 20 Feb 2015 08:44:26 +0000 |
| Subject: | Re: Re: [RFC] Exceptions in the engine | ||
| References: | 1 2 3 4 5 6 7 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-83276@lists.php.net to get a copy of this message | ||
Hi Dmitry,
On Fri, Feb 20, 2015 at 4:15 PM, Dmitry Stogov <dmitry@zend.com> wrote:
> I'm not sure. Currently we don't use namespaces for core classes, but I
> won't object to change this.
> Nikita, what do you think?
>
> Thanks. Dmitry.
>
>
> On Fri, Feb 20, 2015 at 10:01 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote:
>
>> Hi all,
>>
>> On Fri, Feb 20, 2015 at 12:14 AM, Trevor Suarez <rican7@gmail.com> wrote:
>>
>>> I think that naming the new parent exception something like "Throwable"
>>> or
>>> "Catchable" (as Nikita previously suggested) would be a bit more concise
>>> in
>>> meaning than "BaseException". You may not have even meant that name as a
>>> formal proposal, but I figured I'd weigh in regardless. :P
>>>
>>
>> I think they probably should use namespace...
>>
>
I meant users should use namespace to avoid namespace collisions...
We may introduce "PHP" namespace for us to use. I'm +1 for this.
Regards,
--
Yasuo Ohgaki
yohgaki@ohgaki.net