Re: Re: [RFC] Exceptions in the engine
| From: | Pavel Kouřil | Date: | Wed, 25 Feb 2015 13:33:27 +0000 |
| Subject: | Re: Re: [RFC] Exceptions in the engine | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-83785@lists.php.net to get a copy of this message | ||
On Fri, Feb 20, 2015 at 8:01 AM, Yasuo Ohgaki <yohgaki@ohgaki.net> wrote:
> Hi all,
>
> On Fri, Feb 20, 2015 at 12:14 AM, Trevor Suarez <rican7@gmail.com> wrote:
>
>> I think that naming the new parent exception something like "Throwable" or
>> "Catchable" (as Nikita previously suggested) would be a bit more concise in
>> meaning than "BaseException". You may not have even meant that name as a
>> formal proposal, but I figured I'd weigh in regardless. :P
>>
>
> I think they probably should use namespace...
>
> Regards,
>
> --
> Yasuo Ohgaki
> yohgaki@ohgaki.net
Hello,
yes, finally introducing namespaces into PHP core stuff would
definitely be beneficial. Polluting the global namespace more and more
should be avoided.
I would gladly see something like this:
Php\Throwable
- Php\Exception
- Php\ParseException
- Php\EngineException
Of course, the \Exception would need to be kept (maybe as an alias to
\Php\Exception?), for backwards compability.
Regards
Pavel Kouril