Re: [RFC] ifsetor operator
| From: | Marcus Boerger | Date: | Fri, 16 Apr 2004 21:51:47 +0000 |
| Subject: | Re: [RFC] ifsetor operator | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 12 13 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-9291@lists.php.net to get a copy of this message | ||
Hello George,
thinking twice and rechecking it is a bit more complicated though.
"NVL" in oracle means "Null-VaLue" or beter 'NULL Value replacement'.
We want to replace the non-existing situation with a predefined value
which is slightly different.
Hence the name should be "NEL", "NEV" or "NEVAR" for
"Non-Existing-Value-(Replacement)".
sorry i had to read my own mail to recognize this fact.
marcus
Friday, April 16, 2004, 11:43:12 PM, you wrote:
> Friday, April 16, 2004, 10:36:55 PM, you wrote:
>> I vote for nvl(), as the oracle pl/sql function of the same name has
>> this exact semantic.
> Hello George,
> that's avery good idea!
> it is to weird to have a lot of people using this already. And a lot of
> people would expect the exact behavior by its name. Jus because it exists
> elsewhere and there a l ot of people use it.