Re: Re: The death of `#ifndef FAST_ZPP`?
| From: | Andrea Faulds | Date: | Wed, 10 Aug 2016 17:23:15 +0000 |
| Subject: | Re: Re: The death of `#ifndef FAST_ZPP`? | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-95016@lists.php.net to get a copy of this message | ||
Hi Yasuo,
Yasuo Ohgaki wrote:
I've asked the same question before I start eliminating old style parse API. Dimitry said it's designed to optimize heavily called functions, not for ease of use and the RFC for fast zpp states "keep old parameter parsing API", so I don't have to bother.Oh, yeah, I've heard about that. Even if it wasn't specifically intended to be a friendlier API, though, I've heard at least one other person say they prefer using FAST_ZPP, and I prefer it myself. It's more verbose, but it's easier to read at-a-glance, and it makes mistakes more obvious. Thanks. -- Andrea Faulds https://ajf.me/