Re: Class Naming in Core
| From: | Stanislav Malyshev | Date: | Mon, 29 May 2017 23:00:29 +0000 |
| Subject: | Re: Class Naming in Core | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-99244@lists.php.net to get a copy of this message | ||
Hi!
> People are complaining over at Reddit [1]
Isn't it what Reddit is for? ;)
> I know that this is probably a topic nobody cares much about, at least
> we did not end up in this kind of bikeshedding in the UUID discussion
> thread, but it is after all an important question when designing a language.
I personally don't think it is a very important decision, since nothing
much would change either way, but my preference would be:
1. If there's an established acronym, keep it (GMP, DOM, XML, HTTP).
2. If it's just words, use CamelCase.
Second preference is all CamelCase, treating acronyms as a single word
(e.g. RpcOverHttpsViaXml).
--
Stas Malyshev
smalyshev@gmail.com