Re: Re: Class Naming in Core
| From: | Tony Marston | Date: | Tue, 30 May 2017 13:18:21 +0000 |
| Subject: | Re: Re: Class Naming in Core | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-99264@lists.php.net to get a copy of this message | ||
"Rowan Collins" wrote in message news:DC66F890-A033-4EFA-8F2B-CB365C8A4FAC@gmail.com...
On 30 May 2017 09:21:38 BST, Tony Marston <TonyMarston@hotmail.com> wrote:It does not matter. If there was no agreed "standard" to begin with, why should the core developers be forced to make unnecessary changes just because someone that there should now be a standard. Who gives this "someone" the right to demand a change in the name of consistency when the definition of "consistency" has not even been agreed? If it does not cause a problem then no time should be wasted in working on a solution. -- Tony MarstonDifferent projects/teams/organisations are free to use whatever naming convention they like, be it snake_case, CamelCase, studlyCaps or whateverI think the discussion here is which convention we, as the PHP Internals project/team/organisation, want to use. It's nothing to do with forcing anyone else to do anything at all. Regards,