Re: Odd chmod() error in PEAR::Log
| From: | Julien CROUZET | Date: | Mon, 26 Jan 2004 16:03:59 +0000 |
| Subject: | Re: Odd chmod() error in PEAR::Log | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-25286@lists.php.net to get a copy of this message | ||
From: "Joe Stump" <joe@joestump.net>
To: <pear-dev@lists.php.net>
> I'm logging to a file and getting a *strange* log error.
>
> Warning: chmod(): Operation not permitted in
> /home/jstump/public_html/base/includes/PEAR/Log/file.php on line 199
>
> Now the problem is that the log file is chmod'd to 777 - so why can't it
> be chmod'd?
>
If UID != File owner's UID, you can't chmod it.
--
Julien CROUZET
jucrouzet@cpan.org