Re: autoload, include_once naming conventions

From: Date: Thu, 17 Mar 2005 21:55:45 +0000
Subject: Re: autoload, include_once naming conventions
References: 1 2 3 4  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-36732@lists.php.net to get a copy of this message
Stephan Schmidt wrote:
PEAR::loadClass('Foo'); This would load the class and call Foo::__static() if it has been defined. I'd really like to have this in PEAR and it only requires one call to is_callable().
I dont agree. Lets not add more than just ensuring that the code is loaded here. Anything else should be left to __autoload() because that is under the control over the user and he can choose the complexity. I also dont think that we should start implementing our own callback mechanism here. KISS regards, Lukas

« previous php.pear.dev (#36732) next »