Re: autoload, include_once naming conventions
| From: | Joshua Eichorn | Date: | Thu, 17 Mar 2005 23:57:53 +0000 |
| Subject: | Re: autoload, include_once naming conventions | ||
| References: | 1 2 3 4 5 6 7 8 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-36741@lists.php.net to get a copy of this message | ||
Greg Beaver wrote:
Lukas Smith wrote:calling class_exists before every require_once in pear is required to actually make that work. -joshOk, then your __autoload() implementation is pointless. The point of __autoload() is to centralize the loading of code. We will not be able to support people that want to use the include_path for some third party code, __autoload() for some other, and some other hacks for another.The problem is that __autoload() is just about the dumbest implementation choice. I'm sure there were engine restrictions yada yada, but the fact that only 1 can exist dooms it to utter failure on any grand scale. It is only useful on a per-project-no-dependencies basis. I suggest we concentrate on making it easy to write an __autoload() for PEAR classes, and leave it at that (actually, we already do that with the _ => / path mapping so there you go) Greg