Re: autoload, include_once naming conventions
| From: | Daniel Convissor | Date: | Fri, 18 Mar 2005 13:48:34 +0000 |
| Subject: | Re: autoload, include_once naming conventions | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-36751@lists.php.net to get a copy of this message | ||
On Fri, Mar 18, 2005 at 08:30:05AM +0100, Lukas Smith wrote:
>
> To me the naming convention is quite simple:
> Any public class needs to be in its own file that matches the "_" => "/"
>
> style.
It definitely is simple. Cleaning things up is a good idea. But, keep in
mind the other hitch to auto-loading: the "one class per file" is not
mandatory or completely implemented. Again, this is not insurmountable,
but work must be done and BC must be maintained.
--Dan
--
T H E A N A L Y S I S A N D S O L U T I O N S C O M P A N Y
data intensive web and database programming
http://www.AnalysisAndSolutions.com/
4015 7th Ave #4, Brooklyn NY 11232 v: 718-854-0335 f: 718-854-0409