Re: Re: [PEPr] Comment on File Formats::File_Fortune
| From: | Matthew Weier O'Phinney | Date: | Fri, 01 Jul 2005 13:16:53 +0000 |
| Subject: | Re: Re: [PEPr] Comment on File Formats::File_Fortune | ||
| References: | 1 2 3 4 5 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-38411@lists.php.net to get a copy of this message | ||
On 7/1/05, Sergio Carvalho <sergio.carvalho@portugalmail.com> wrote:
> Christian Weiske wrote:
> > > Primarily that I don't have PHP4 on any box I can test on. I can make it
> > > PHP4-friendly if necessary.
> >
> > If php5 isn't absoluteley necessary, it should work with php4.
>
> I disagree. It isn't possible to be E_STRICT compliant and still work
> with PHP4.
>
> I guess It's up to the developer. If the dev is using PHP5, he should go
> E_STRICT compliant.
This would be my preference. I have both versions ready.
The one question Christian did bring up regarding PHP5 compat is that the error
constants need to be class constants; I haven't seen any examples of how these
should be named, and Christian couldn't direct me to any. With the global
constants, you prepend the package name, with _ERROR: 'FILE_FORTUNE_ERROR_....'
What is the naming convention for class error constants? 'ERROR_...'?
--
Matthew Weier O'Phinney
mweierophinney@gmail.com
http://weierophinney.net/matthew/