[PEPr] Comment on Networking::Net_SMPP
| From: | Philippe Jausions | Date: | Tue, 19 Jul 2005 22:09:27 +0000 |
| Subject: | [PEPr] Comment on Networking::Net_SMPP | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-38748@lists.php.net to get a copy of this message | ||
Philippe Jausions (http://pear.php.net/user/jausions) has commented on the proposal for
Networking::Net_SMPP.
Comment:
Beside the class naming issue, I think you should do some benchmarking of
the $_defs array vs. a switch() implementation of it.
Usually switch it the faster then array creation and if statement. But it
may not in your case or it may make things more difficult. The
investigation *may* bring performance increase.
-Philippe
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=239
--
Sent by PEPr, the automatic proposal system at http://pear.php.net