[PEPr] Comment on Images::Image_Canvas
| From: | Tobias Schlitt | Date: | Wed, 20 Jul 2005 20:24:21 +0000 |
| Subject: | [PEPr] Comment on Images::Image_Canvas | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-38811@lists.php.net to get a copy of this message | ||
Tobias Schlitt (http://pear.php.net/user/toby) has commented on the proposal for
Images::Image_Canvas.
Comment:
A few hints/wishes from my point of view:
- rename write() to addText()
- split done() save() and show()
- me personally hates functions with extremly long parameter lists, use
arrays with speaking keys, that's more comfortable (or even better: offer
the possibility to use a hashmap instead of single params, but allow this
also)
Beside that, I like the package. :) Please get in touch with Kore
regarding the use in Image_3D. I believe he has some more ideas.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=212
--
Sent by PEPr, the automatic proposal system at http://pear.php.net