Re: Naming convensions
| From: | Lukas Smith | Date: | Thu, 04 Aug 2005 08:19:20 +0000 |
| Subject: | Re: Naming convensions | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39199@lists.php.net to get a copy of this message | ||
Clay Loveless wrote:
On 8/3/05 11:23 AM Pacific Time, Joe Stump (joe@joestump.net) wrote:I have to agree here. I severely tend towards underscores, while I have noticed alot of other developers tending towards using lower bumby camel. Finding a standard this late in the game is tricky, but we could come up with one. Either way I agree the key aspect is that a given package atleast does this consistently. regards, LukasI would concur with the others that variables *should* be humpBack since functions are and, from what I can tell, it appears to be a defacto standard of sorts.I think we need something better than a "de facto standard of sorts" ... It's either in the Coding Standards, or it's not, period. There's nothing in the documentation that discusses variable naming conventions, only function/method names. Personally, I don't make the leap that just because functions are namedLikeThis that variables should be also. In fact, as I said last week, I feel exactly the opposite -- and until the day that the Coding Standards are updated to specifically address variable names, I will not consider my choice to name_variables_like_this to be incorrect, invalid, or not recommended.