Re: Naming convensions
| From: | Philippe Jausions | Date: | Thu, 04 Aug 2005 16:30:56 +0000 |
| Subject: | Re: Naming convensions | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39218@lists.php.net to get a copy of this message | ||
Clay Loveless wrote:
On 8/4/05 8:24 AM Pacific Time, Stoyan Stefanov (ssttoo@gmail.com) wrote:Given the history of the packages and factoring BC in, we're strapped no matter what. The only thing to be done is damage control for future and currently none-stable packages. At least in-package consistency should be mandatory, regardless of properies' visibility IMO. One more point to consider in that case is also indexes in $options arrays, which is widely used in PEAR packages. Anyway, no matter which naming convention is agreed on, we can only make it a strong recommendation, with breaking of the rule only for extremely good reasons. -PhilippeIt looks like the more recent packages tend towards using $someVars. So I guess the manual can state something like: "While using $some_vars used to acceptable, it's now discouraged in favor of $someVars. Newly created packages MUST use $someVars in order to be considered. This applies to all variables regardless of their scope."But that is the point I'm making -- it is NOT discouraged. There's nothing in the documentation that discourages it. The packages who have chosen $someVar as public variables have simply not looked to packages that came before them for the example/precendent that had been set. That is hardly a recommendation. Seems like this needs to either get a directive from PEAR Group, or a vote via PEPr.