[PEPr] Comment on Web Services::Services_JSON
| From: | bertrand Gugger | Date: | Fri, 12 Aug 2005 21:42:02 +0000 |
| Subject: | [PEPr] Comment on Web Services::Services_JSON | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39342@lists.php.net to get a copy of this message | ||
bertrand Gugger (http://pear.php.net/user/toggg) has commented on the proposal for Web
Services::Services_JSON.
Comment:
Your class should be named "Services_JSON" or "PHP_JSON" but not
"JSON"
Looks like everything is static, $this only for $this->use ? Is it not
quite a constant ?
I'm still wondering if such a processing for each char (encode strings)
could not be reduced ... no dichotomy possible ?
Anyway, I appreciate your refactoring of this part even if switch(){} is
not so popular.
Hope to use it ... and forget I use it.
Bon courage.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=198
--
Sent by PEPr, the automatic proposal system at http://pear.php.net