Re: [PEPr] Comment on Web Services::Services_JSON

From: Date: Mon, 10 Oct 2005 15:29:23 +0000
Subject: Re: [PEPr] Comment on Web Services::Services_JSON
References: 1 2  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-40125@lists.php.net to get a copy of this message
On 10 Oct 2005 05:10:50 -0000, Michal Migurski <mike-pear@teczno.com> wrote: > > Michal Migurski (http://pear.php.net/user/migurski) has commented on the proposal for Web > Services::Services_JSON. > > Comment: > > Thanks Justin - those all sound like good suggestions. I generally prefer > sprintf() because it looks cleaner in my editor, but if there's a > performance reason to eschew it I'm happy to switch. You must be a C programmer then. ;-) 'pre'.$var.'post' should also syntax highlight just fine and is easier to read than sprintf since it puts the var right where it's output. Actually, the "official" way to do this is: 'pre' . $var . 'post' which is easier ot read. > > dec() and enc() are just shorthand synonyms for the encode() & decode() > methods. I realize this, of course. I was just wondering why there were these synonyms. If it's to conform to some kind of standard then ok, but IMHO you really don't need multiple synonyms for a function unless you're trying to keep backwards compatibility with something. > > Proposal information: > http://pear.php.net/pepr/pepr-proposal-show.php?id=198 > > -- > Sent by PEPr, the automatic proposal system at > http://pear.php.net > > -- > PEAR Development Mailing List (http://pear.php.net/) > To unsubscribe, visit: http://www.php.net/unsub.php > > -- Justin Patrin

« previous php.pear.dev (#40125) next »