[PEPr] +1 for Web Services::Services_JSON
| From: | Philippe Jausions | Date: | Thu, 13 Oct 2005 18:24:58 +0000 |
| Subject: | [PEPr] +1 for Web Services::Services_JSON | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-40170@lists.php.net to get a copy of this message | ||
Philippe Jausions (http://pear.php.net/user/jausions) has voted +1 on the proposal for Web
Services::Services_JSON.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=198
Vote information:
http://pear.php.net/pepr/pepr-vote-show.php?id=198&handle=jausions
This vote is conditional. The condition is:
The conditions are minor:
- drop the duplicate methods enc() and dec(). They don't save much in typing from encode() and
decode() which have much clearer names
- Prepend an "_" to the private method names name_value() and reduce_string()
- I'm not super happy with the name of the package. This is not a "service" package
per-se, but just a serializer one.
- Whatever name the package will be, the constant names need to be fixed.
- Since the use of OOP in this package is extremely limited, I would suggest to go static and use
&PEAR::getStaticProperty instead with a Service_JSON::setMode() kind of method.
--
Sent by PEPr, the automatic proposal system at http://pear.php.net