Re: [PEPr] -1 for Tools and Utilities::CodeGen_MySQL_UDF
| From: | Jesper Veggerby Hansen | Date: | Thu, 01 Sep 2005 08:29:03 +0000 |
| Subject: | Re: [PEPr] -1 for Tools and Utilities::CodeGen_MySQL_UDF | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-39677@lists.php.net to get a copy of this message | ||
I can appreciate the method names not being compliant, but I have other
issues:
1) Indentation is messed up : don't use tabs
2) Private members are not prefixed with _
3) Inline phpdoc tags are missing some places
4) You have a dependency on PHP5: why not use the functionality it
provides fx. in terms of access modifiers?
You use the PHP5 functionality to some extent in your base class static
methods, abstract classes. Why do you
rely on the "documentation" way for access, i.e. '@access private', when
you can do 'private funtion ...'?
5) Maybe this just relates to 3 + 4:
In Function.php there are 2 methods : cData() and cPrototype(), which have
no phpdoc tags, no access modifier => public,
then the names are not well chosen.
"6") Is more to the process - it should ring a bell that nobody commented
on the proposal, I think you ought to have "asked" the mailinglist for
comments before voting (which is normally thought of as good practice). I
(as some others) missed the proposal mail.
This is not (in itself) the reason why I voted -1 - the code probably
works and all, I just think there are things that need to be changed
before it is accepted, and I don't really think the community got a fair
chance on giving input!
But this is maybe just my humble opinion?
regards
Jesper
> Jesper Veggerby wrote:
>> Has anybody bothered looking at the code before voting?
>>
>> Idea maybe good, but changes need to be made to comply with CS!
>
> Are you referring to the method names in ExtensionParser.php?
>
> If its anything else then please let me know, if its this
> then it's clearly a "won't fix"
>
> These are not compliant for the same reason the ones on
> CodeGen/ExtensionParser.php and CodeGen_PECL/ExtensionParser.php
> are not: these are just internal callbacks for the XML parser
> and while i can live with the lower readability of studlyCaps
> i wont give in on them here, the underscore is used as a tag
> name delimiter in the method name for a reason
>