Re: Re: PEAR inclusion request: php_jh_pdf

From: Date: Wed, 10 Apr 2002 17:24:56 +0000
Subject: Re: Re: PEAR inclusion request: php_jh_pdf
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-5312@lists.php.net to get a copy of this message
Hi folks, bjoern@baer.main.de: > Is it similar to http://pc4p.sourceforge.net/ ? After having a look at it: Yes, it is. So it looks like Alexander and me have developed two similar things. This was not my intention. However, now there ARE two projects and probably only one will make it into PEAR. Of course I like my approach more, but that's only because it has exactly the API I want, which is no wonder as I designed it. I think we'll have to see which API the other people prefer and the more popular project should go into PEAR. This is the 'survival of the fittest' game and I won't be angry if Alexander's project will make it. bmansion@mamasam.com: > I have looked at PC4P but it does not handle PDI (PDF Import) functions of > PDFLib which is an absolute need for a PDF wrapper class. PC4P seems also a > bit closed in terms of architecture, it handles the PDF from its creation > (even before the pdf_open call). It is quite difficult to plug your own > methods in PC4P. This is why I would prefer your approach which is closer to > what I would need and also seems more open. I do not have immediate plans to implement a PDI wrapper class. But as you wrote it's no problem to use the PDI functions while still using my PDF classes. I'll probably add something to handle the document-level stuff (PDF_open(), PDF_new_page, etc.), but I'll always try to keep its use optional. > You might want to change the name of your class for a better and simplier > one, have a deeper look at PC4P, include PDI functionalities, have a look at > HTML_Table for table handling ;) You might also want to create an PDF_Common > class which would handle attributes for tables, cells, rows, colors, fonts, > size, alignment ... the way you want. This could be based on HTML > specifications ? I know that the name "php_jh_pdf" is ugly, i've only chosen it because I'm too lazy to think of a better one and using my initials is the best way to avoid name clashes. If you have some idea, let me know! I have plans to abstract the table (and maybe other) definitions in some way. Maybe HTML, maybe XML, I'm not currently aware of a good solution. Any suggestions? In the meanwhile I have released a new version. The freshmeat annoncement should appear soon. The project homepage still is http://www.bettina-attack.de/jonny/projects/php_jh_pdf Cheers, Jonny <jonny@1409.org>

« previous php.pear.dev (#5312) next »