Re: phpDocumentor2 vs. PEAR2_PHPDocumentor (which name should we choose)
| From: | Michael Gauthier | Date: | Tue, 15 Jun 2010 19:38:01 +0000 |
| Subject: | Re: phpDocumentor2 vs. PEAR2_PHPDocumentor (which name should we choose) | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-53566@lists.php.net to get a copy of this message | ||
On Tue, 2010-06-15 at 09:34 -0500, Chuck Burgess wrote:
> On Tue, Jun 15, 2010 at 9:04 AM, Brett Bieber <brett.bieber@gmail.com>wrote:
>
> > On Tue, Jun 15, 2010 at 8:39 AM, Shawn Stratton <sstratton@php.net> wrote:
> > > I've had the pleasure of seeing the name discussed a few times already
> > > and as such would like to find out once and for all which name is
> > > preferred before James and I dig too far and get too stuck to one name
> > > or the other. As such I'd like to ask for a vote of what the package
> > > name should be. I'll tally up what everyone thinks and James and I
> > > will stick with that.
> >
> > PEAR2 standards require namespace prefix of PEAR2. The standards also
> > state that acronyms should be capitalized, eg PHP.
> > http://wiki.php.net/pear/rfc/pear2_standards
> >
> > --
> > Brett Bieber
> >
>
>
> I'm inclined to agree with Brett, to make it a PEAR2 app and follow the
> PEAR2 naming convention of \PEAR2\PHPDocumentor...
I'd like to see it as PEAR2_PHPDocumentor as well. Keep in mind that the
PEAR2 namespace is the vendor namespace. It would still make sense in
documentation to refer to the package as PHPDocumentor, or even
phpDocumentor.
Cheers,
Mike