Re: phpDocumentor2 vs. PEAR2_PHPDocumentor (which name should we choose)
| From: | Shawn Stratton | Date: | Tue, 15 Jun 2010 20:21:53 +0000 |
| Subject: | Re: phpDocumentor2 vs. PEAR2_PHPDocumentor (which name should we choose) | ||
| References: | 1 2 3 4 5 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-53568@lists.php.net to get a copy of this message | ||
Brett,
The namespacing has been in compliance since James and I discussed
Pear2, although I must say it's been PEAR2/phpDocumentor2, depending
on what Chuck or Greg think should be the distinction on the phpdoc2,
phpDocumentor vs. phpDocumentor2, but my question was more about the
popular package name, and my question actually came from a jab you
made on irc about a week ago. So I guess the question continues, also
for the record one thing James and I are working to ensure is that the
cli command and it's switches/options remain consistent with what
already exists (ie. we're adding and trying very hard not to take
away, rename, or change.) For the most part, the end user should not
have a problem converting from 1.x to our package, except for
templates as we are not supporting smarty and have not yet decided
what to do about the template rendering system.
Shawn Stratton
Zend Certified Engineer
phpDocumentor 2 Developer
On Tue, Jun 15, 2010 at 3:50 PM, Brett Bieber <brett.bieber@gmail.com> wrote:
> On Tue, Jun 15, 2010 at 2:38 PM, Michael Gauthier <mike@silverorange.com> wrote:
>> On Tue, 2010-06-15 at 09:34 -0500, Chuck Burgess wrote:
>>> On Tue, Jun 15, 2010 at 9:04 AM, Brett Bieber <brett.bieber@gmail.com>wrote:
>>>
>>> > On Tue, Jun 15, 2010 at 8:39 AM, Shawn Stratton <sstratton@php.net> wrote:
>>> > > I've had the pleasure of seeing the name discussed a few times already
>>> > > and as such would like to find out once and for all which name is
>>> > > preferred before James and I dig too far and get too stuck to one name
>>> > > or the other. As such I'd like to ask for a vote of what the package
>>> > > name should be. I'll tally up what everyone thinks and James and I
>>> > > will stick with that.
>>> >
>>> > PEAR2 standards require namespace prefix of PEAR2. The standards also
>>> > state that acronyms should be capitalized, eg PHP.
>>> > http://wiki.php.net/pear/rfc/pear2_standards
>>> >
>>> > --
>>> > Brett Bieber
>>> >
>>>
>>>
>>> I'm inclined to agree with Brett, to make it a PEAR2 app and follow the
>>> PEAR2 naming convention of \PEAR2\PHPDocumentor...
>>
>> I'd like to see it as PEAR2_PHPDocumentor as well. Keep in mind that the
>> PEAR2 namespace is the vendor namespace. It would still make sense in
>> documentation to refer to the package as PHPDocumentor, or even
>> phpDocumentor.
>
> I agree with this. I think we all recognize that phpDocumentor has a
> brand and unique relationship with the community.. and certainly I
> would encourage the use of the existing brand and reputation. That
> said — the actual code namespace should conform with the standards. It
> isn't a big issue as most people don't program against phpDocumentor's
> API, they use the cli tool which certainly could be named phpdoc2,
> perhaps even phpdoc if the cli options remain similar. I'd even be up
> for discussing using the package name of phpDocumentor, so pyrus
> install pear2/phpDocumentor or phpDocumentor2 would work. So I guess
> what I'm saying is, hang on to that phpDocumentor association as much
> as you can... just keep the code in compliance with the standards so
> that autoloading, file placement etc is consistent.
>
> --
> Brett Bieber
>