[PEPr] +1 for Web Services::Mailman
| From: | Ken Guest | Date: | Fri, 20 Jan 2012 01:55:21 +0000 |
| Subject: | [PEPr] +1 for Web Services::Mailman | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-54727@lists.php.net to get a copy of this message | ||
Ken Guest (http://pear.php.net/user/kguest) has voted +1 on the proposal for Web Services::Mailman.
Proposal information:
http://pear.php.net/pepr/pepr-proposal-show.php?id=672
Vote information:
http://pear.php.net/pepr/pepr-vote-show.php?id=672&handle=kguest
This vote is conditional. The condition is:
Take care of these and I'm happy:
* Returning a value immediately after throwing an exception is redundant - that code won't get
executed so don't include it in the first place.
* I'd subclass Exception to Services_Mailman_Exception.
* There's inconsistent use/lack of use of whitespace; eg.
'send_unsub_ack_to_this_batch'=>0 versus 'send_welcome_msg_to_this_batch'
=> 0
* You don't need to prepend the method name to the exception message - the method name
isn't going to change so I'd hardcode it and avoid using the __METHOD__ magic constant and
concatenation.