Re: pear(1): Could not open input file.

From: Date: Tue, 25 Jun 2002 15:03:22 +0000
Subject: Re: pear(1): Could not open input file.
References: 1 2 3 4 5  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-7344@lists.php.net to get a copy of this message
> Date: Tue, 25 Jun 2002 16:47:49 +0200 > From: "Tomas V.V.Cox" <cox@idecnet.com> > To: Roman Neuhauser <neuhauser@bellavista.cz> > CC: pear-dev <pear-dev@lists.php.net> > Subject: Re: [PEAR-DEV] pear(1): Could not open input file. > > Roman Neuhauser wrote: > > > > > Date: Tue, 25 Jun 2002 15:48:09 +0200 > > > From: "Tomas V.V.Cox" <cox@idecnet.com> > > > To: Roman Neuhauser <neuhauser@bellavista.cz> > > > CC: pear-dev <pear-dev@lists.php.net> > > > Subject: Re: [PEAR-DEV] pear(1): Could not open input file. > > > > > > Umm, seems that FreeBSD doesn't allow such interpreter > > > (#!@prefix@/bin/php -Cqd include_path=@include_path@), I've changed it > > > in CVS. Thanks for the report. > > > > it looks like you didn't bother reading the patch I sent along > > the mail, or even the message for that matter. > > I did read the message and spend the time trying to find a FreeBSD for > testing it, find the time to fix it and even to reply to your message. > > > revert your commit, it doesn't help anything. > > Your patch is wrong, removing the -Cq will break compat with php-cgi. what compat? checkout HEAD on a system w/o any prior version of PHP and try running pear. FYI, the cgi SAPI in HEAD is installed in @prefix@/bin/php-cgi, not @prefix@/bin/php. > Why it doesn't help? because the problem is not with the -d option. the problem is that if you install HEAD and try running pear, it'll bomb out on two unknown options, -C and -q. -- FreeBSD 4.6-STABLE 4:59PM up 1 day, 13:59, 8 users, load averages: 0.00, 0.01, 0.00

« previous php.pear.dev (#7344) next »