Re: naming conventions: final
| From: | Stig S. Bakken | Date: | Mon, 21 Aug 2000 20:52:05 +0000 |
| Subject: | Re: naming conventions: final | ||
| References: | 1 2 3 | Groups: | php.pear |
| Request: | Send a blank email to php-pear+get-196@lists.php.net to get a copy of this message | ||
Ulf Wendel wrote:
>
> Chuck Hagenbuch wrote:
> >
> > Quoting Ulf Wendel <UW@NetUSE.DE>:
> >
> > > how about another naming convention for final slots:
> > >
> > > class package_modul_name {
> > > var $FINAL_SLOT = "just another diry way to get OOPHP before
> > > 2021";
> > > }
> >
> > So to clarify, you're suggesting that class member variables that don't
> > change - that are essentially constants - should be in all caps?
>
> Yepp, we do mean the same.
I'm fine with that. Feel free to stick it into
pearweb/public_html/doc/pear.xml.
- Stig