Re: [PHP4BETA] bug or feature (with phpMyAdmin 2.0.2)?

From: Date: Thu, 22 Jul 1999 19:14:42 +0000
Subject: Re: [PHP4BETA] bug or feature (with phpMyAdmin 2.0.2)?
References: 1  Groups: php.version4 
Request: Send a blank email to php-version4+get-2547@lists.php.net to get a copy of this message
Hi, I use phpMyAdmin-2.0.1. It seems that the bug you spoke of affects this version as well. When I click on select I get "Document contains no data" error message. Your fix has fixed the problem. Also I detected a similar problem when using the "View Dump (schema) of table feature." Again the error message. I fixed this by replacing replacing require("header.inc.php3") and require("lib.inc.php3"); with include statements instead. This is at the very beginning of the tbl_dump.php3 file. Just as you did. This seems to have fixed the problem. Using php3 does not generate the same problem. I should know since I was using php3 and calling database dumps regularly. But as I said, I'm using phpMyAdmin2.0.1. Not sure if the same problems occurs in 2.0.2. Thanks for the fix. Eddie Azman Quoting Mike Ravkin <mike@acidsearch.com>: > I just tested it. And you're right, I get the same problem, and i'm > absolutely > sure it worked fine with php3. > (your fix also fixes the problem, thanks =) > > That does lead me to conclude that there's some kind of odd bug under > php4... > > At 01:22 PM 7/22/99 , Oliver Heering wrote: > > > > Hi, > > > > it seems that phpMyAdmin 2.0.2 doesn't work correctly with PHP4B1. If > > I open the properties of a table and click on the "select" link (below > > "browse"), all I get is a blank page with the content: > > > > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> > > </HTML> > > > > Nothing more, nothing less. > > > > The cause for this error is definitely in line 107 in the file > > tbl_select.php3 where it says: > > > > require("sql.php3"); > > > > Interestingly the error disappears when you change it to: > > > > include("sql.php3"); > > > > Now, is this a bug of PHP4 (because it runs totally flawless under > > PHP 3.0.x)? Or is it a bug in phpMyAdmin and therefore a bug in PHP > > 3.0.x that it runs without error? > > > > /-------------------------------------------------------------------\ > > | page: http://www.ocrana.de | | > > _ \ | > > | | __| | _ \ | | | > > | mail: sLoP@ocrana.de | \__ \ | ( | ___/ | > > | cya | ____/_____|\___/ _| | > > \-------------------------------------------------------------------/ > > > > > > > > -- > > PHP 4 Beta > > > Eddie ---------------------- Audentes Fortuna Juvat ---------------------------------------------------------------- Get your free Email address today at http://www.linuxcountry.com

« previous php.version4 (#2547) next »