Re: [PHP4BETA] bug or feature (with phpMyAdmin 2.0.2)?

From: Date: Thu, 22 Jul 1999 23:02:14 +0000
Subject: Re: [PHP4BETA] bug or feature (with phpMyAdmin 2.0.2)?
References: 1  Groups: php.version4 
Request: Send a blank email to php-version4+get-2575@lists.php.net to get a copy of this message
Oliver Heering wrote: > > Hi, > > it seems that phpMyAdmin 2.0.2 doesn't work correctly with PHP4B1. If > I open the properties of a table and click on the "select" link (below > "browse"), all I get is a blank page with the content: > > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> > <HTML><HEAD> > <META content="text/html; charset=windows-1252" > http-equiv=Content-Type></HEAD> > <BODY></BODY></HTML> > > Nothing more, nothing less. > > The cause for this error is definitely in line 107 in the file > tbl_select.php3 where it says: > > require("sql.php3"); > > Interestingly the error disappears when you change it to: > > include("sql.php3"); > > Now, is this a bug of PHP4 (because it runs totally flawless under > PHP 3.0.x)? Or is it a bug in phpMyAdmin and therefore a bug in PHP That suggests to me that you have a phpx_include_path in your apache config file and sql.php3 isn't in one of the directories specified in the directive. jason

« previous php.version4 (#2575) next »