Re: [PHP4BETA] IIS4, ISAPI, NT4(SP5), PHP

From: Date: Tue, 11 Jan 2000 11:18:29 +0000
Subject: Re: [PHP4BETA] IIS4, ISAPI, NT4(SP5), PHP
Groups: php.version4 
Request: Send a blank email to php-version4+get-9031@lists.php.net to get a copy of this message
It happend to me. The error was that in my config file (php.ini) the browscap=xxx pointed on the file used by IIS4, and the file sharing was not possible, making PHP crash during php's error message processing. I made a copy of the file, and changed 'browcap' to point on the new file. That actually doesn't help me very much though, since now PHP makes IIS4 blow (error in inetinfo.exe) This might not help you, since I guess that any error message from php produces the same symptom. I suggest to recompile PHP (good luck, took me 4 hours to setup a somehow incomplete build under windows, due to messy libraries configuration), and put debug messages everywhere to figure out what's going on. Redirecting the regular PHP error messages in a file could be a good alternative too. I wish we could know at least if somebody uses successfully PHP4 beta3 with IIS4, and that the complete Windows setup (including libraries not belonging to php) could be provided by the developpers, so we might try to figure out what's going on. Last, but not least, it seems to us that IIS4 is a very unstable product. So unstable that we probably will migrate to something else too. Jean "Flynn" Flinois <flynn@vtech.fr> V-Technologies, Savennieres -----Message d'origine----- De : System Administrator <sysadmin@cheezy.net> À : php4beta@lists.php.net <php4beta@lists.php.net> Date : mardi 11 janvier 2000 11:49 Objet : [PHP4BETA] IIS4, ISAPI, NT4(SP5), PHP I don't know what it is... beta 3 has caused IIS to crash twice. The only recovery has been to fully reboot the system. Are there actually any NT/IIS users out there? We're truly thinking of switching to Apache32. (probably a good idea, yeah?) The beta was running fine for a few days, with only server-side include type tags on pages. Then, when we tried to start getting fancier (logon script), PHPISAPI.DLL seems to have conked out. IIS was half-functioning only and required a reboot to fix. After the reboot, PHPISAPI.DLL had generated an error in the Event Log, and we were unable to use it. We have had to shut down PHP and revert to a temporary, old version of the site. I could not find any specific error messages beyond that in the Event Log: _______________________________________________________________ 11.01.00 12:47:44 Description: The HTTP server encountered an unhandled exception while processing the ISAPI Application 'C:\php4\php4isapi.dll'. _______________________________________________________________ 11.01.00 01:15:23 Description: The HTTP server was unable to load the ISAPI Application 'C:\php4\php4isapi.dll'. The data is the error. Data Bytes: 0000: e6 03 00 00 æ... Data Words: 0000: 000003e6 _______________________________________________________________ The second error happened twice (we rebooted again to make sure) Any suggestions? Hints? james. -- PHP 4.0 Beta Mailing List <http://www.php.net/version4/> To unsubscribe, e-mail: php4beta-unsubscribe@lists.php.net For additional commands, e-mail: php4beta-help@lists.php.net To contact the list administrators, e-mail: php4beta-admin@lists.php.net

« previous php.version4 (#9031) next »