Bug #17671 Updated: fails with GD

From: Date: Mon, 17 Jun 2002 03:12:24 +0000
Subject: Bug #17671 Updated: fails with GD
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-10816@lists.php.net to get a copy of this message
ID: 17671 Updated by: sniper@php.net Reported By: colin.harford@mail.su.ualberta.ca -Status: Open +Status: Bogus Bug Type: GD related Operating System: OpenBSD 3.1-current PHP Version: 4.0CVS-2002-06-09 New Comment: Where is gd.h located in your system? (besides the one in the php4 sources) Previous Comments: ------------------------------------------------------------------------ [2002-06-16 16:02:09] colin.harford@mail.su.ualberta.ca No dice: (kajack!/root/php4-200206161200) [root-ttyp1] # /var/opt/apache2/bin/apachectl start /usr/libexec/ld.so: Undefined symbol "_gdFontGiant" in httpd:/opt/apache2/modules/libphp4.so /var/opt/apache2/bin/apachectl start: httpd could not be started btw: /opt = /var/opt (symlink) ------------------------------------------------------------------------ [2002-06-15 21:43:58] sniper@php.net I can not reproduce this within Linux. (with Apache2) Can you please try your original configure line with the latest snapshot and also check that the installed libphp4.so really is the latest and correct one. (the paths in your error messages don't quite match the configure paths..?) ------------------------------------------------------------------------ [2002-06-13 16:27:11] colin.harford@mail.su.ualberta.ca It loads the page just fine... Is this what you wanted? (kajack!/proc/8731) [root-ttyp0] # /root/php4-200206131200/php /root/acid/acid_main.php X-Powered-By: PHP/4.3.0-dev Set-Cookie: PHPSESSID=eb15a629846feb9edd12b63cf06c7e05; path=/ Expires: Thu, 19 Nov 1981 08:52:00 GMT Cache-Control: no-store, no-cache, must-revalidate, post- check=0, pre-check=0 Pragma: no-cache Content-type: text/html <!doctype html public "-//w3c//dtd html 4.0 transitional// en"> <!-- Analysis Console for Incident Databases (ACID) 0.9.6b21 --> <HTML> <HEAD> <META name="Author" content="Roman Danyliw"> <META HTTP-EQUIV="pragma" CONTENT="no-cache"> <META HTTP-EQUIV="REFRESH" CONTENT="180"; URL="";> <TITLE>Analysis Console for Intrusion Databases (ACID) </ TITLE> <LINK rel="stylesheet" type="text/css" href= "acid_style.css"> </HEAD> <BODY> <TABLE WIDTH="100%" BORDER=0 CELLSPACING=0 CELLPADDING=5> <TR> <TD class="mainheader"> &nbsp </TD> <TD class="mainheadertitle"> <U>A</U>nalysis <U>C</U>onsole for <U>I</U>ntrusion < U>D</U>atabases </TD> </TR> </TABLE> <P><P> <P><B>Error loading the DB Abstraction library: </B> from "/adodb.inc.php"<P>Check the DB abstraction library variable <CODE>$DBlib_path</CODE> in <CODE>acid_conf.php</ CODE> <P> The underlying database library currently used is ADODB, that can be downloaded at <A HREF="http://php.weblogs.com/adodb"> http://php.weblogs.com/adodb</A> (kajack!/proc/8731) [root-ttyp0] ------------------------------------------------------------------------ [2002-06-12 19:15:27] sniper@php.net That configure line does not make any apache2 module.. Please try again, this time with fresh sources from http://snaps.php.net/ (the latest non-stable snapshot) and after using the same short configure line I gave, do 'make' and then try some script with the php binary found in the same directory where you run configure in. ------------------------------------------------------------------------ [2002-06-12 16:00:36] colin.harford@mail.su.ualberta.ca (kajack!/root/php4-200206120900) [root-ttyp1] # /opt/apache2/bin/apachectl start /usr/libexec/ld.so: Undefined symbol "_gdFontGiant" in httpd:/opt/apache2/modules/libphp4.so /opt/apache2/bin/apachectl start: httpd could not be started Nope, no dice! CH ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/17671 -- Edit this bug report at http://bugs.php.net/?id=17671&edit=1

« previous php.bugs (#10816) next »