Bug #17671 Updated: fails with GD
| From: | colin dot harford at mail dot su dot ualberta dot ca | Date: | Fri, 28 Jun 2002 21:03:47 +0000 |
| Subject: | Bug #17671 Updated: fails with GD | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-12452@lists.php.net to get a copy of this message | ||
ID: 17671
Updated by: colin.harford@mail.su.ualberta.ca
Reported By: colin.harford@mail.su.ualberta.ca
-Status: Closed
+Status: Open
Bug Type: GD related
Operating System: OpenBSD 3.1-current
PHP Version: 4.0CVS-2002-06-09
New Comment:
Something still not happy.... the ./configure is the exact
same as earlier....
(kajack!/root/php4-200206281200) [root-ttyp3]
# make install
/root/php4-200206281200/build/shtool mkdir -p "/opt/
apache2/modules" && /var/opt/apache2/bin/apxs -S
LIBEXECDIR="/opt/apache2/modules" -i -a -n php4 libphp4.la
/opt/apache2/build/instdso.sh SH_LIBTOOL='/opt/apache2/
build/libtool' libphp4.la /opt/apache2/modules
/opt/apache2/build/libtool --mode=install cp libphp4.la /
opt/apache2/modules/
cp .libs/libphp4.lai /opt/apache2/modules/libphp4.la
cp .libs/libphp4.a /opt/apache2/modules/libphp4.a
ranlib -t /opt/apache2/modules/libphp4.a
chmod 644 /opt/apache2/modules/libphp4.a
libtool: install: warning: remember to run `libtool --
finish /root/php4-200206281200/libs'
mv: rename /opt/apache2/modules/ to /opt/apache2/modules/
libphp4.so: Invalid argument
chmod 755 /opt/apache2/modules/libphp4.so
chmod: /opt/apache2/modules/libphp4.so: No such file or
directory
apxs:Error: Command failed with rc=65536
.
*** Error code 1
Stop in /root/php4-200206281200 (line 123 of Makefile).
Previous Comments:
------------------------------------------------------------------------
[2002-06-28 14:53:02] derick@php.net
You will need apache's CVS version too... (We can't help they keep
changing the API with every micro version :(
Derick
------------------------------------------------------------------------
[2002-06-28 13:15:10] colin.harford@mail.su.ualberta.ca
checking for Apache 2.0 module support via DSO through
APXS... configure: error: Please note that Apache version >
= 2.0.40 is required.
Ummm, checking the apache site, and the latest release is
2.0.39.
------------------------------------------------------------------------
[2002-06-28 03:49:03] sniper@php.net
This bug has been fixed in CVS. You can grab a snapshot of the
CVS version at http://snaps.php.net/. In case this was a
documentation
problem, the fix will show up soon at http://www.php.net/manual/.
In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites.
Thank you for the report, and for helping us make PHP better.
Now if you build with the bundled GD library, the include
path for ext/gd/libgd/ is the first one. So it shouldn't
get that system gd.h anymore..
------------------------------------------------------------------------
[2002-06-17 10:35:43] sniper@php.net
Cynic, please READ the reports before you bogus them.
This is actually about our BUNDLED GD..reopened.
------------------------------------------------------------------------
[2002-06-17 00:07:18] cynic@php.net
looks like you have two versions of gd installed in different places.
wipe out all but the one you actually want to use and try again.
if this doesn't fix your problem, reopen the PR.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/17671
--
Edit this bug report at http://bugs.php.net/?id=17671&edit=1