Bug #17671 Updated: fails with GD
| From: | cynic@php.net | Date: | Mon, 17 Jun 2002 04:07:19 +0000 |
| Subject: | Bug #17671 Updated: fails with GD | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-10821@lists.php.net to get a copy of this message | ||
ID: 17671
Updated by: cynic@php.net
Reported By: colin.harford@mail.su.ualberta.ca
-Status: Open
+Status: Bogus
Bug Type: GD related
Operating System: OpenBSD 3.1-current
PHP Version: 4.0CVS-2002-06-09
New Comment:
looks like you have two versions of gd installed in different places.
wipe out all but the one you actually want to use and try again.
if this doesn't fix your problem, reopen the PR.
Previous Comments:
------------------------------------------------------------------------
[2002-06-16 23:20:14] colin.harford@mail.su.ualberta.ca
# find / -name gd.h
/usr/include/gd.h
/usr/local/include/gd.h
/var/opt/packages/gd-1.8.4/gd.h
/var/opt/packages/gd-2.0.1/gd.h
------------------------------------------------------------------------
[2002-06-16 23:12:41] sniper@php.net
oops..feedback it was..
------------------------------------------------------------------------
[2002-06-16 23:12:24] sniper@php.net
Where is gd.h located in your system?
(besides the one in the php4 sources)
------------------------------------------------------------------------
[2002-06-16 16:02:09] colin.harford@mail.su.ualberta.ca
No dice:
(kajack!/root/php4-200206161200) [root-ttyp1]
# /var/opt/apache2/bin/apachectl start
/usr/libexec/ld.so: Undefined symbol "_gdFontGiant" in
httpd:/opt/apache2/modules/libphp4.so
/var/opt/apache2/bin/apachectl start: httpd could not be
started
btw: /opt = /var/opt (symlink)
------------------------------------------------------------------------
[2002-06-15 21:43:58] sniper@php.net
I can not reproduce this within Linux. (with Apache2)
Can you please try your original configure line
with the latest snapshot and also check that
the installed libphp4.so really is the latest and correct one.
(the paths in your error messages don't quite match the configure
paths..?)
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/17671
--
Edit this bug report at http://bugs.php.net/?id=17671&edit=1