ID: 19702
User updated by: steveneu@visi.com
Reported By: steveneu@visi.com
-Status: Feedback
+Status: Open
Bug Type: Apache related
Operating System: FreeBSD 4.7
PHP Version: 4.2.3
New Comment:
All I get is:
[Wed Oct 2 12:16:04 2002] [error] [client 161.225.1.12] Premature end
of script headers: /usr/local/share/nagios/cgi-bin//cmd.cgi
in the http-error.log
If I remove mod_php from the httpd.conf it works fine.
Is there a way to get more info?
Previous Comments:
------------------------------------------------------------------------
[2002-10-02 10:50:53] sander@php.net
Check your error_log.
------------------------------------------------------------------------
[2002-10-01 21:10:37] steveneu@visi.com
I am unable to successfully execute any CGIs (PERL or C) while the
PHP module is enabled. The CGI simply fails with an internal server
error in the browser and premature end of script headers in the http
error log. If I disable mod_php everything works fine.
I am running apache 1.3.26 with mod_ssl (from the ports collection).
sidenote: I CAN run CGIs when I enable the fastcgi module but only
GETs. POSTs return an internal server error/premature end of script
headers. Weird, eh?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19702&edit=1