#19702 [Opn->Csd]: Internal Server Error on CGIs with mod_php4 enabled

From: Date: Wed, 16 Oct 2002 14:42:43 +0000
Subject: #19702 [Opn->Csd]: Internal Server Error on CGIs with mod_php4 enabled
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-22577@lists.php.net to get a copy of this message
ID: 19702 User updated by: steveneu@visi.com Reported By: steveneu@visi.com -Status: Open +Status: Closed Bug Type: Apache related Operating System: FreeBSD 4.7 PHP Version: 4.2.3 New Comment: I recompiled php4.2.3 manually with the configure options that I previously posted and I was able to run CGIs. There must be a problem with the FreeBSD port. I'll try to contact the port maintainer/ports mailing list and see what they have to say. Previous Comments: ------------------------------------------------------------------------ [2002-10-15 06:14:29] steveneu@visi.com Here's what I have in config.nice. I'm compiling from the ports collection so I actually pick the options from a dialog and freebsd's make actually does the "configure, make, make install" './configure' \ '--with-apxs=/usr/local/sbin/apxs' \ '--with-config-file-path=/usr/local/etc' \ '--enable-versioning' \ '--with-regex=system' \ '--without-gd' \ '--without-mysql' \ '--with-gd=/usr/local' \ '--enable-gd-native-ttf' \ '--with-freetype-dir=/usr/local' \ '--with-jpeg-dir=/usr/local' \ '--with-png-dir=/usr/local' \ '--with-zlib' \ '--with-mysql=/usr/local' \ '--with-ldap=/usr/local' \ '--enable-ftp' \ '--with-curl=/usr/local' \ '--with-gettext=/usr/local' \ '--with-pspell=/usr/local' \ '--with-mcal=/usr/local' \ '--prefix=/usr/local' \ ------------------------------------------------------------------------ [2002-10-14 23:57:37] sniper@php.net That simple 'printenv' script works (and has always worked) just fine here so I'm pretty sure your configuration is somewhat broken. I suggest you try with stock apache httpd.conf and then do a clean install of PHP. (please add your configure line for PHP here btw) ------------------------------------------------------------------------ [2002-10-14 23:20:44] steveneu@visi.com nope, no cgi will work using mod_cgi. perl scripts if run via mod_perl work fine. cgi's via fastCGI kinda work... POSTs fail with an internal server error, GETs work fine ------------------------------------------------------------------------ [2002-10-14 22:54:45] sniper@php.net Does any simple cgi scripts work..like the apache provided exampe printenv script? ------------------------------------------------------------------------ [2002-10-14 22:16:07] steveneu@visi.com I dunno... unless something changed in the syntax. My cgi's definitely worked before upgrading too. I was messing a cgi based monitoring tool (nagios) a few days before the upgrade. It worked and then it didn't. It took me a few days to notice but the only event between the "working" and "non-working" state was the upgrade. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19702 -- Edit this bug report at http://bugs.php.net/?id=19702&edit=1

« previous php.bugs (#22577) next »