#19702 [Fbk->Opn]: Internal Server Error on CGIs with mod_php4 enabled

From: Date: Tue, 15 Oct 2002 04:20:44 +0000
Subject: #19702 [Fbk->Opn]: Internal Server Error on CGIs with mod_php4 enabled
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-22461@lists.php.net to get a copy of this message
ID: 19702 User updated by: steveneu@visi.com Reported By: steveneu@visi.com -Status: Feedback +Status: Open Bug Type: Apache related Operating System: FreeBSD 4.7 PHP Version: 4.2.3 New Comment: nope, no cgi will work using mod_cgi. perl scripts if run via mod_perl work fine. cgi's via fastCGI kinda work... POSTs fail with an internal server error, GETs work fine Previous Comments: ------------------------------------------------------------------------ [2002-10-14 22:54:45] sniper@php.net Does any simple cgi scripts work..like the apache provided exampe printenv script? ------------------------------------------------------------------------ [2002-10-14 22:16:07] steveneu@visi.com I dunno... unless something changed in the syntax. My cgi's definitely worked before upgrading too. I was messing a cgi based monitoring tool (nagios) a few days before the upgrade. It worked and then it didn't. It took me a few days to notice but the only event between the "working" and "non-working" state was the upgrade. ------------------------------------------------------------------------ [2002-10-14 18:50:01] sniper@php.net This is very likely a problem with your apache configure. Try using the stock httpd.conf and add the correct PHP related lines. ------------------------------------------------------------------------ [2002-10-14 14:41:21] fran@his.com Got the same problem after upgrading to mod_php 4.2.3 perl and shell scripts executed as cgi started giving error 500, despite they have been running fine before. They were running fine from shell. Disabling mod_php4 in apache httpd.conf restored the normal behavior. We had to roll back the upgrade. Please let us know when this will be fixed Other info: FreeBSD 4.7, apache 1.3.27 Hope this helps others... Francoise ------------------------------------------------------------------------ [2002-10-02 12:26:16] steveneu@visi.com All I get is: [Wed Oct 2 12:16:04 2002] [error] [client 161.225.1.12] Premature end of script headers: /usr/local/share/nagios/cgi-bin//cmd.cgi in the http-error.log If I remove mod_php from the httpd.conf it works fine. Is there a way to get more info? ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19702 -- Edit this bug report at http://bugs.php.net/?id=19702&edit=1

« previous php.bugs (#22461) next »