ID: 19702
User updated by: steveneu@visi.com
Reported By: steveneu@visi.com
-Status: Feedback
+Status: Open
Bug Type: Apache related
Operating System: FreeBSD 4.7
PHP Version: 4.2.3
New Comment:
I dunno... unless something changed in the syntax.
My cgi's definitely worked before upgrading too. I was messing a cgi
based monitoring tool (nagios) a few days before the upgrade. It worked
and then it didn't. It took me a few days to notice but the only event
between the "working" and "non-working" state was the upgrade.
Previous Comments:
------------------------------------------------------------------------
[2002-10-14 18:50:01] sniper@php.net
This is very likely a problem with your apache configure.
Try using the stock httpd.conf and add the correct PHP related lines.
------------------------------------------------------------------------
[2002-10-14 14:41:21] fran@his.com
Got the same problem after upgrading to mod_php 4.2.3
perl and shell scripts executed as cgi started giving error 500,
despite they have been running fine before.
They were running fine from shell.
Disabling mod_php4 in apache httpd.conf restored the normal behavior.
We had to roll back the upgrade.
Please let us know when this will be fixed
Other info: FreeBSD 4.7, apache 1.3.27
Hope this helps others...
Francoise
------------------------------------------------------------------------
[2002-10-02 12:26:16] steveneu@visi.com
All I get is:
[Wed Oct 2 12:16:04 2002] [error] [client 161.225.1.12] Premature end
of script headers: /usr/local/share/nagios/cgi-bin//cmd.cgi
in the http-error.log
If I remove mod_php from the httpd.conf it works fine.
Is there a way to get more info?
------------------------------------------------------------------------
[2002-10-02 10:50:53] sander@php.net
Check your error_log.
------------------------------------------------------------------------
[2002-10-01 21:10:37] steveneu@visi.com
I am unable to successfully execute any CGIs (PERL or C) while the
PHP module is enabled. The CGI simply fails with an internal server
error in the browser and premature end of script headers in the http
error log. If I disable mod_php everything works fine.
I am running apache 1.3.26 with mod_ssl (from the ports collection).
sidenote: I CAN run CGIs when I enable the fastcgi module but only
GETs. POSTs return an internal server error/premature end of script
headers. Weird, eh?
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19702&edit=1