#18600 [Com]: Unable to create Java Virtual Machine
| From: | gskumar at quark dot co dot in | Date: | Fri, 17 Jan 2003 09:56:29 +0000 |
| Subject: | #18600 [Com]: Unable to create Java Virtual Machine | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-30337@lists.php.net to get a copy of this message | ||
ID: 18600
Comment by: gskumar@quark.co.in
Reported By: nalves@equifax.com.br
Status: Open
Bug Type: Java related
Operating System: Windows 2000
PHP Version: 4.2.3
New Comment:
Hi all,
How my servlet will call my php program.
Any pointer appreciated.
Surendra.
Previous Comments:
------------------------------------------------------------------------
[2003-01-08 17:14:33] zzpeterzz@yahoo.com
I HAVE A NEC 95 WINDOWS NOTEBOOK AND CANNOT INSTALL THE JAVA VIRTUAL
MACHINE PLUG IT COMES BACK AND TELLS ME THIS THE PUBLISHERCANNOT BE
DETERMINED DUE TO TO PROBLEMS AND THIS AS WELL TRUST PROVIDER IS
UNKNOWN OR NOT CONFIGURED PROPERLY CAN U PLEASE TELL ME WHAT I CAN DO
TO REMEDY THIS?????? THANK YOU PETER FIORE.
------------------------------------------------------------------------
[2003-01-07 03:51:23] lebeau.frederic@skynet.be
THANKS TO Alberto.Sarini@libero.it ,
The solution to resolve "Unable to Create Java Virtual
Machine" is to configure APACHE or IIS not using sapi for php but CGI
THANKS THANKS THANKS
go there for configuration
http://hotwired.lycos.com/webmonkey/00/44/index4a_page9.html?tw=programming
------------------------------------------------------------------------
[2002-12-12 09:19:13] Alberto.Sarini@libero.it
Hi there,
I'm confirming Cédric's knowledge - java is running correctly from
within PHP on Apache only when PHP is running as a CGI and not as a
SAPI module. When running PHP as Apache SAPI Module after the restart
Apache only fist access to php page using java is running OK, all next
reloads of this page caused "Fatal error: Unable to create Java Virtual
Machine in ..."
I think this could be still not solved bug.
Thanks
Alberto
BTW I'm running on:
OS:Win2000 Server SP2
Apache:1.3.27
PHP Version 4.3.0-dev (Build Date Dec 12 2002 10:14:28)
Java version=1.4.1_01
Java vendor=Sun Microsystems Inc.
------------------------------------------------------------------------
[2002-12-06 05:06:27] Alberto.Sarini@libero.it
Hi,
using "cgi-bin instead of as a module"
hm,isn't this a performance and computer resources issue ?
Thx
Alberto
------------------------------------------------------------------------
[2002-12-05 15:15:35] Tangara@advalvas.be
I had the same bug but after having looking a lot, I find
a solution.
You just have to configure php as a cgi-bin instead of as
a module and it works perfectly.
Hoping it will help you to fix the bug in the module.
Cédric.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/18600
--
Edit this bug report at http://bugs.php.net/?id=18600&edit=1