Re: include_path question
| From: | Sascha Schumann | Date: | Sun, 27 Aug 2000 20:13:18 +0000 |
| Subject: | Re: include_path question | ||
| References: | 1 | Groups: | php.dev |
| Request: | Send a blank email to php-dev+get-30848@lists.php.net to get a copy of this message | ||
> It is used by SAPI modules only. If you want to document that the
> main_script needs to be full-path then go ahead.
You imply it is well-defined, I call it a convenience function.
> I really don't think it's
> correct to add such code just in case one of the SAPI modules doesn't set
> it correctly. If we get to that bridge we can re-evaluate the situation and
> we might decide to go your way but right now there is no reason to do it
> except for adding bloat (and bugs).
Unless you have evaluated all SAPI modules, saying "right now
there is no reason to do it" is unreasonable.
> Recently I have been trying to clean things up a bit which includes a slow
> cleaning up of fopen_wrappers.c. I don't want to have such special case
> code hanging around PHP anymore so let's not add more to it.
And I've been trying to move more stuff from the SAPI modules
to the core of PHP where it belongs. I don't want to have
such general cases hanging around SAPI modules anymore.
- Sascha