Re: include_path question

From: Date: Sun, 27 Aug 2000 21:35:01 +0000
Subject: Re: include_path question
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-30858@lists.php.net to get a copy of this message
At 23:13 27/08/2000, Sascha Schumann wrote:
It is used by SAPI modules only. If you want to document that the main_script needs to be full-path then go ahead.
    You imply it is well-defined, I call it a convenience function.
Well, it's one of the better-defined functions during the PHP 4.0 life cycle. Its behavior never changed since its introduction, more or less. And, if it changes, it'll affect each and every SAPI module. It's pretty much API.
    And I've been trying to move more stuff from the SAPI modules
    to the core of PHP where it belongs. I don't want to have
    such general cases hanging around SAPI modules anymore.
This is a blessed motivation, if it's possible. I haven't checked into this particular issue, but I can see why it could be problematic to deal with that stuff in the SAPI core, as opposed to each and every SAPI module. The paths to the file for execution is one of the things you obtain in many different ways in the various platforms, and generalizing it may cause more trouble than good. This has little, or practically nothing, to do with the definition of PATH_TRANSLATED, SCRIPT_FILENAME and others in the symbol table. This should *definitely* be generalized, but if the calculation of these values isn't itself generalizable, it should be done like most other stuff is done in SAPI; It should be the responsibility of the SAPI module to calculate this and put it into the request_info structure, and the centralized core will define it if it exists. Lets wait with this until post 4.0.2, though. About moral churches and the likes... I'd suggest on not getting carried away on such things. If Andi said the patch was morally wrong with a smile, you can figure out it's not the same as say, murder is morally wrong. It was a figure of speech, moral in its literal sense had nothing to do with it. Zeev -- Zeev Suraski <zeev@zend.com> http://www.zend.com/

« previous php.dev (#30858) next »