Re: convention about function naming

From: Date: Sun, 17 Dec 2000 17:11:24 +0000
Subject: Re: convention about function naming
References: 1  Groups: php.dev 
Request: Send a blank email to php-dev+get-41662@lists.php.net to get a copy of this message
On Sun, 17 Dec 2000, Zeev Suraski wrote: >True! I was just thinking the same..:) Just add socket_ or sock_ prefix to them? Having some function called shutdown() is not very good thing (tm) :) And as this extension is useless (does not compile) e.g. on Solaris this would be good time to rename them..this is experimental extension still, isn't it? (in EXTENSIONS status is Unknown) --Jani >At 21:36 16/12/2000, André Langhorst wrote: >>Just realized that the somehow new socket extension does not follow the >>function naming convention made some day, why? >>It uses very common function names like write(),read() etc. >> >>I think this should be changed as fast as possible... >>As far as users are starting to activate that extension they will have to >>rewrite their scripts eventually >> >>andré >> >> >>-- >>PHP Development Mailing List <http://www.php.net/> >>To unsubscribe, e-mail: php-dev-unsubscribe@lists.php.net >>For additional commands, e-mail: php-dev-help@lists.php.net >>To contact the list administrators, e-mail: php-list-admin@lists.php.net > >-- >Zeev Suraski <zeev@zend.com> >CTO & co-founder, Zend Technologies Ltd. >http://www.zend.com/ > > >

« previous php.dev (#41662) next »